虛擬區域網路

虛擬區域網路

VLAN(Virtual Local Area Network)的中文名為"虛擬區域網路"。

虛擬區域網路(VLAN)是一組邏輯上的設備和使用者,這些設備和使用者並不受物理位置的限製,可以根據功能、部門及套用等因素將它們組織起來,相互之間的通信就好像它們在同一個網段中一樣,由此得名虛擬區域網路。VLAN是一種比較新的技術,工作在OSI參考模型的第2層和第3層,一個VLAN就是一個廣播域,VLAN之間的通信是通過第3層的路由器來完成的。與傳統的區域網路技術相比較,VLAN技術更加靈活,它具有以下優點: 網路設備的移動、增加和修改的管理開銷減少;可以控製廣播活動;可提高網路的安全性。

在電腦網路中,一個二層網路可以被劃分為多個不同的廣播域,一個廣播域對應了一個特定的使用者組,默認情況下這些不同的廣播域是相互隔離的。不同的廣播域之間想要通信,需要通過一個或多個路由器。這樣的一個廣播域就稱為VLAN。

  • 中文名稱
    虛擬區域網路
  • 外文名稱
    virtual local area network

基本介紹

IEEE于1999年頒布了用以標準化VLAN實現方案的802.1Q協定標準草案。VLAN技術的出現,使得管理員根據實際套用需求,把同一物理區域網路內的不同使用者邏輯地劃分成不同的廣播域,每一個VLAN都包含一組有著相同需求的電腦工作站,與物理上形成的LAN有著相同的屬性。由于它是從邏輯上劃分,而不是從物理上劃分,所以同一個VLAN內的各個工作站沒有限製在同一個物理範圍中,即這些工作站可以在不同物理LAN網段。由VLAN的特點可知,一個VLAN內部的廣播和單播流量都不會轉發到其他VLAN中,從而有助于控製流量、減少設備投資、簡化網路管理、提高網路的安全性。

虛擬區域網路

交換技術的發展,也加快了新的交換技術(VLAN)的套用速度。通過將企業網路劃分為虛擬網絡VLAN網段,可以強化網路管理和網路安全,控製不必要的資料廣播。在共享網路中,一個物理的網段就是一個廣播域。而在交換網路中,廣播域可以是有一組任意選定的第二層網路地址MAC地址)組成的虛擬網段。這樣,網路中工作組的劃分可以突破共享網路中的地理位置限製,而完全根據管理功能來劃分。這種基于工作流的分組模式,大大提高了網路規劃和重組的管理功能。在同一個VLAN中的工作站,不論它們實際與哪個交換機連線,它們之間的通訊就好象在獨立的交換機上一樣。同一個VLAN中的廣播隻有VLAN中的成員才能聽到,而不會傳輸到其他的VLAN中去,這樣可以很好的控製不必要的廣播風暴的產生。同時,若沒有路由的話,不同VLAN之間不能相互通訊,這樣增加了企業網路中不同部門之間的安全性。網路管理員可以通過配置VLAN之間的路由來全面管理企業內部不同管理單元之間的信息互訪。交換機是根據交換機的連線埠來劃分VLAN的。所以,使用者可以自由的在企業網路中移動辦公,不論他在何處接入交換網路,他都可以與VLAN內其他使用者自如通訊。

VLAN網路可以是有混合的網路類型設備組成,比如:10M乙太網、100M乙太網、令牌網、FDDI、CDDI等等,可以是工作站、伺服器、集線器、網路上行主幹等等。

虛擬區域網路

VLAN除了能將網路劃分為多個廣播域,從而有效地控製廣播風暴的發生,以及使網路的拓撲結構變得非常靈活的優點外,還可以用于控製網路中不同部門、不同站點之間的互相訪問。

VLAN是為解決乙太網的廣播問題和安全性而提出的一種協定,它在乙太網幀的基礎上增加了VLAN頭,用VLAN ID把使用者劃分為更小的工作組,限製不同工作組間的使用者互訪,每個工作組就是一個虛擬區域網路。虛擬區域網路的好處是可以限製廣播範圍,並能夠形成虛擬工作組,

協定目的

VLAN(Virtual Local Area Network,虛擬區域網路)的目的非常的多。通過認識VLAN的本質,將可以了解到其用處究竟在哪些地方。

第一,要知道192.168.1.2/30和192.168.2.6/30都屬于不同的網段,都必須要通過路由器才能進行訪問,凡是不同網段間要互相訪問,都必須通過路由器。

第二,VLAN本質就是指一個網段,之所以叫做虛擬的區域網路,是因為它是在虛擬的路由器的接口下建立的網段。

下面,給予說明。比如一個路由器隻有一個用于終端連線的連線埠(當然這種情況基本不可能發生,隻不過簡化舉例),這個連線埠被分配了192.168.1.1/24的地址。然而由于公司有兩個部門,一個銷售部,一個企劃部,每個部門要求單獨成為一個子網,有單獨的伺服器。那麽當然可以劃分為192.168.1.0--127/25、192.168.1.128--255/25。但是路由器的物理連線埠隻應該可以分配一個IP地址,那怎樣來區分不同網段了?這就可以在這個物理連線埠下,建立兩個子接口---邏輯接口實現。

比如邏輯接口F0/0.1就分配IP地址192.168.1.1/25,用于銷售部,而F0/0.2就分配IP地址192.168.1.129/25,用于企劃部。這樣就等于用一個物理連線埠確實現了兩個邏輯接口的功能,這樣就將原本隻能劃分一個網段的情形,擴展到了可以劃分2個或者更多個網段的情形。這些網段因為是在邏輯接口下建立的,所以稱之為虛擬區域網路VLAN。

這是在路由器的層次上闡述了VLAN的目的。

第三,將在交換機的層次上闡述VLAN的目的。

在現實中,由于很多原因必須劃分出不同網段。比如就簡單的隻有銷售部和企劃部兩個網段。那麽可以簡單的將銷售部全部接入一個交換機,然後接入路由器的一個連線埠,把企劃部全部接入一個交換機,然後接入一個路由器連線埠。這種情況是LAN.然而正如上面所說,如果路由器就一個用于終端的接口,那麽這兩個交換機就必須接入這同一個路由器的接口,這個時候,如果還想保持原來的網段的劃分,那麽就必須使用路由器的子接口,建立VLAN.

同樣,比如兩個交換機,如果你想要每個交換機上的連線埠都分別屬于不同的網段,那麽你有幾個網段,就提供幾個路由器的接口,這個時候,雖然在路由器的物理接口上可以定義這個接口可以連線哪個網段,但是在交換機的層次上,它並不能區分哪個連線埠屬于哪個網段,那麽唯一實現能區分的方法,就是劃分VLAN,使用了VLAN就能區分出某個交換機連線埠的終端是屬于哪個網段的。

綜上,當一個交換機上的所有連線埠中有至少一個連線埠屬于不同網段的時候,當路由器的一個物理連線埠要連線2個或者以上的網段的時候,就是VLAN發揮作用的時候,這就是VLAN的目的。

產品優點

廣播風暴防範

限製網路上的廣播,將網路劃分為多個VLAN可減少參與廣播風暴的設備數量。LAN分段可以防止廣播風暴波及整個網路。VLAN可以提供建立防火牆的機製,防止交換網路的過量廣播。使用VLAN,可以將某個交換連線埠或使用者賦于某一個特定的VLAN組,該VLAN組可以在一個交換網中或跨接多個交換機,在一個VLAN中的廣播不會送到VLAN之外。同樣,相鄰的連線埠不會收到其他VLAN產生的廣 播。這樣可以減少廣播流量,釋放頻寬給使用者套用,減少廣播的產生。

安全

增強區域網路的安全性,含有敏感資料的使用者組可與網路的其餘部分隔離,從而降低泄露機密信息的可能性。不同VLAN內的報文在傳輸時是相互隔離的,即一個VLAN內的使用者不能和其它VLAN內的使用者直接通信,如果不同VLAN要進行通信,則需要通過路由器三層交換機等三層設備。

成本降低

成本高昂的網路升級需求減少,現有頻寬和上行鏈路的利用率更高,因此可節約成本。

性能提高

將第二層平面網路劃分為多個邏輯工作組(廣播域)可以減少網路上不必要的流量並提高性能。

提高IT員工效率

VLAN為網路管理帶來了方便,因為有相似網路需求的使用者將共享同一個VLAN。

套用管理

VLAN 將使用者和網路設備聚合到一起,以支持商業需求或地域上的需求。通過職能劃分,項目管理或特殊套用的處理都變得十分方便,例如可以輕松管理教師的電子教學開發平台。此外,也很容易確定升級網路服務的影響範圍。

增加網路連線的彈性

借助VLAN技術,能將不同地點、不同網路、不同使用者組合在一起,形成一個虛擬的網路環境,就像使用在地LAN一樣方便、靈活、有效。VLAN可以降低移動或變更工作站地理位置的管 理費用,特別是一些業務情況有經常性變動的公司使用了VLAN後,這部分管理費用大大降低。

組建條件

VLAN是建立在物理網路基礎上的一種邏輯子網,因此建立VLAN需要相應的支持VLAN技術的網路設備。當網路中的不同VLAN間進行相互通信時,需要路由的支持,這時就需要增加路由設備——要實現路由功能,既可採用路由器,也可採用三層交換機來完成。同時還嚴格限製了使用者數量.

功能劃分

根據連線埠來劃分VLAN

許多VLAN廠商都利用交換機的連線埠來劃分VLAN成員。被設定的連線埠都在同一個廣播域中。例如,一個交換機的1,2,3,4,5連線埠被定義為虛擬網AAA,同一交換機的6,7,8連線埠組成虛擬網BBB。這樣做允許各連線埠之間的通訊,並允許共享型網路的升級。但是,這種劃分模式將虛擬網限製在了一台交換機上。

第二代連線埠VLAN技術允許跨越多個交換機的多個不同連線埠劃分VLAN,不同交換機上的若幹個連線埠可以組成同一個虛擬網。

以交換機連線埠來劃分網路成員,其配置過程簡單明了。因此,從目前來看,這種根據連線埠來劃分VLAN的方式仍然是最常用的一種方式。

根據MAC地址劃分VLAN

這種劃分VLAN的方法是根據每個主機的MAC地址來劃分,即對每個MAC地址的主機都配置它屬于哪個組。這種劃分VLAN方法的最大優點就是當使用者物理位置移動時,即從一個交換機換到其他的交換機時,VLAN不用重新配置,所以,可以認為這種根據MAC地址的劃分方法是基于使用者的VLAN,這種方法的缺點是初始化時,所有的使用者都必須進行配置,如果有幾百個甚至上千個使用者的話,配置是非常累的。而且這種劃分的方法也導致了交換機執行效率的降低,因為在每一個交換機的連線埠都可能存在很多個VLAN組的成員,這樣就無法限製廣播包了。另外,對于使用筆電的使用者來說,他們的網卡可能經常更換,這樣,VLAN就必須不停地配置。

根據網路層劃分VLAN

這種劃分VLAN的方法是根據每個主機的網路層地址或協定類型(如果支持多協定)劃分的,雖然這種劃分方法是根據網路地址,比如IP地址,但它不是路由,與網路層的路由毫無關系。

這種方法的優點是使用者的物理位置改變了,不需要重新配置所屬的VLAN,而且可以根據協定類型來劃分VLAN,這對網路管理者來說很重要,還有,這種方法不需要附加的幀標簽來識別VLAN,這樣可以減少網路的通信量。

這種方法的缺點是效率低,因為檢查每一個封包的網路層地址是需要消耗處理時間的(相對于前面兩種方法),一般的交換機晶片都可以自動檢查網路上封包的乙太網幀頭,但要讓晶片能檢查IP幀頭,需要更高的技術,同時也更費時。當然,這與各個廠商的實現方法有關。

根據IP組播劃分VLAN

IP 組播實際上也是一種VLAN的定義,即認為一個組播組就是一個VLAN,這種劃分的方法將VLAN擴大到了廣域網,因此這種方法具有更大的彈性,而且也很容易通過路由器進行擴展,當然這種方法不適合區域網路,主要是效率不高。

基于規則的VLAN

也稱為基于策略的VLAN。這是最靈活的VLAN劃分方法,具有自動配置的能力,能夠把相關的使用者連成一體,在邏輯劃分上稱為“關系網路”。網路管理員隻需在網管軟體中確定劃分VLAN的規則(或屬性),那麽當一個站點加入網路中時,將會被“感知”,並被自動地包含進正確的VLAN中。同時,對站點的移動和改變也可自動識別和跟蹤。

採用這種方法,整個網路可以非常方便地通過路由器擴展網路規模。有的產品還支持一個連線埠上的主機分別屬于不同的VLAN,這在交換機與共享式Hub共存的環境中顯得尤為重要。自動配置VLAN時,交換機中軟體自動檢查進入交換機連線埠的廣播信息的IP源地址,然後軟體自動將這個連線埠分配給一個由IP子網對應成的VLAN。

按使用者劃分VLAN

基于使用者定義、非使用者授權來劃分VLAN,是指為了適應特別的VLAN網路,根據具體的網路使用者的特別要求來定義和設計VLAN,而且可以讓非VLAN群體使用者訪問VLAN,但是需要提供使用者密碼,在得到VLAN管理的識別後才可以加入一個VLAN。

* 以上劃分VLAN的方式中,基于連線埠的VLAN連線埠方式建立在物理層上;MAC方式建立在資料鏈路層上;網路層和IP廣播方式建立在第三層上。

國際標準

對VLAN的標準,我們隻是介紹兩種比較通用的標準,當然也有一些公司具有自己的標準,比如Cisco公司的ISL標準,雖然不是一種大眾化的標準,但是由于Cisco Catalyst交換機的大量使用,ISL也成為一種不是標準的標準了。

· 802.10VLAN標準

在1995年,Cisco公司提倡使用IEEE802.10協定。在此之前,IEEE802.10曾經在全球範圍內作為VLAN安全性的同一規範。Cisco公司嘗試採用最佳化後的802.10幀格式在網路上載輸FramTagging模式中所必須的VLAN標簽。然而,大多數802委員會的成員都反對推廣802.10。因為,該協定是基于FrameTagging方式的。

· 802.1Q

在1996年3月,IEEE802.1Internetworking委員會結束了對VLAN初期標準的修訂工作。新出台的標準進一步完善了VLAN的體系結構,統一了Frame-Tagging方式中不同廠商的標簽格式,並製定了VLAN標準在未來一段時間內的發展方向,形成的802.1Q的標準在業界獲得了廣泛的推廣。它成為VLAN史上的一塊裏程碑。802.1Q的出現打破了虛擬網依賴于單一廠商的僵局,從一個側面推動了VLAN的迅速發展。另外,來自市場的壓力使各大網路廠商立刻將新標準融合到他們各自的產品中。

802.1q幀格式:

虛擬區域網路

· Cisco ISL 標簽

ISL(Inter-Switch Link)是Cisco公司的專有封裝方式,因此隻能在Cisco的設備上支持。ISL是一個在交換機之間、交換機與路由器之間及交換機與伺服器之間傳遞多個VLAN信息及VLAN資料流的協定,通過在交換機直接的連線埠配置ISL封裝,即可跨越交換機進行整個網路的VLAN分配和配置。

基本策略

從技術角度講,VLAN的劃分可依據不同原則,一般有以下三種劃分方法:

基于連線埠

這種劃分是把一個或多個交換機上的幾個連線埠劃分一個邏輯組,這是最簡單、最有效的劃分方法。該方法隻需網路管理員對網路設備的交換連線埠進行重新分配即可,不用考慮該連線埠所連線的設備。

基于MAC地址

MAC地址其實就是指網卡標識符,每一塊網卡的MAC地址都是唯一且固化在網卡上的。MAC地址由12位16進位數表示,前6位為網卡的廠商標識(OUI),後6位為網卡標識(NIC)。網路管理員可按MAC地址把一些站點劃分為一個邏輯子網。

基于路由

路由協定工作在網路層,相應的工作設備有路由器和路由交換機(即三層交換機)。該方式允許一個VLAN跨越多個交換機,或一個連線埠位于多個VLAN中。

就目前來說,對于VLAN的劃分主要採取上述第1、3種方式,第2種方式為輔助性的方案。

發展趨勢

目前在寬頻網路中實現的VLAN基本上能滿足廣大網路使用者的需求,但其網路性能、網路流量控製、網路通信優先權控製等還有待提高。前面所提到的VTP技術、STP技術,基于三層交換的VLAN技術等在VLAN使用中存在網路效率的瓶頸問題,這主要是IEEE802.1Q、IEEE802.1D協定的不完善所致,IEEE正在製定和完善IEEE802.1S(Multiple Spanning Trees)和IEEE802.1W(Rapid Reconfiguration of Spanning Tree)來改善VLAN的性能。採用IEEE802.3z和IEEE802.3ab協定,並結合使用RISC(精簡指令集計算)處理器或者網路處理器而研製的吉位VLAN交換機在網路流量等方面採取了相應的措施,大大提高了VLAN網路的性能。IEEE802.1P協定提出了COS(Class of Service)標準,這使網路通信優先權控製機製有了參考。

配置命令

1、建立vlan方法一 

switch#vlan database

switch(vlan)#vlan 10 name wz

switch(vlan)#exit  

2、建立vlan方法二  

switch(config)#vlan 10 

switch(config-vlan)#name wz  

3、移除vlan方法一 

switch(vlan)#no vlan 10 

switch(vlan)#exit  

4、移除vlan方法二  

switch(config)#no interface vlan 10

switch(config)#no vlan 10

5、移除vlan方法三

switch#delete vlan.dat

6、將連線埠加入到vlan中

switch(config-if)#switchport access vlan 10

7、將一組連續的連線埠加入到vlan中

switch(config)# interface range f0/1 –5

switch(config)#interface range f0/6-8,0/9-11,0/22

(將不連續多個連線埠加入到Vlan中)

switch(config-if-range)#switchport access vlan 10

8、將連線埠從vlan中移除

switch(config-if)#no switchport access vlan 10

switch(config-if)#switchport access vlan 1

switch(config-if-range)#no switchport access vlan 10

switch(config-if-range)#switchport access vlan 1

9、查看所有vlan的摘要信息

switch#show vlan brief

10、查看指定vlan的信息

switch#show vlan id 10

11、指定連線埠成為trunk

switch(config-if)#switchport mode trunk

12、Trunk的自動協商

switch(config-if)#switchport mode dynamic desirable

switch(config-if)#switchport mode dynamic auto

註意:如果中繼鏈路兩端都設定成auto將不能成為trunk

13、查看連線埠狀態

switch#show interface f0/2 switchport

14、在trunk上移出vlan

switch(config-if)#switchport trunk allowed vlan remove 20

15、在trunk上增加vlan

switch(config-if)#switchport trunk allowed vlan add 20

劃分實例

對于每個公司而言都有自己不同的需求,下面我們給出一個典型的公司的VLAN的實例,這樣也可以成為我們以後為公司劃分VLAN的依據。

某公司現在有工程部、銷售部、財務部。VLAN的劃分:工程部VLAN10,銷售部VLAN20,財務部VLAN30,並且各部門還可以相互通訊。現有設備如下:Cisco 3640路由器,Cisco Catalyst 2924交換機一台,二級交換機若幹台。

交換機配置檔案中的部分代碼如下:

……

!

interface vlan10

ip address 192.168.0.1

!

interface vlan20

ip address 192.168.1.1

!

interface vlan30

ip address 192.168.2.1

!

……

路由器配置檔案中的部分代碼如下:

……

interface FastEthernet 1/0.1

encapsulation isl 10

ip address 192.168.0.2

!

interface FastEthernet 1/0.2

encapsulation isl 20

ip address 192.168.1.2

!

interface FastEthernet 1/0.3

encapsulation isl 30

ip address 192.168.2.2

!

……

!

router rip

network 192.168.0.0

!

【交換機的連線埠工作模式的利用】

交換機的連線埠工作模式通常可以分為三種,它們分別為Access模式、Multi模式、Trunk模式。允許多個vlan的是multi模式,而不是trunk模式。Access模式的交換連線埠往往隻能屬于1個VLAN,通常用于連線普通電腦的連線埠;Trunk模式的交換連線埠可以屬于多個VLAN,能夠傳送和接收多個VLAN的資料報文,通常使用在交換機之間的級聯連線埠上;multi模式的交換連線埠可以屬于多個VLAN,能夠傳送和接受多個VLAN的資料報文,可以用于交換機之間的連線,也可以用于連線普通電腦的連線埠,所以access和trunk沒有可比性。三種模式的交換連線埠能夠共同使用在相同的一台交換機中,不過Trunk模式的交換連線埠和multi模式的交換連線埠相互之間不能直接切換,往往隻能先將交換連線埠設定為Access模式,之後再設定為其他模式。

拓撲試驗

實驗: 劃分VLAN

1. 實驗目的

通過本實驗,讀者可以掌握如下技能:

(1)熟悉VLAN 的建立

(2)把交換機接口劃分到特定VLAN

2. 實驗拓撲

虛擬區域網路

實驗拓撲圖

3. 實驗步驟

要配置VLAN,首先要先建立VLAN,然後才把交換機的連線埠劃分到特定的連線埠上:

(1) 步驟1:在劃分VLAN 前,配置R1 和R2 路由器的g0/0 接口,從R1ping192.168.12.2。

默認時,交換機的全部接口都在VLAN1 上,R1 和R2 應該能夠通信

(2) 步驟2:在S1 上建立VLAN

S1#vlan database

//進入到VLAN 配置模式

S1(vlan)#vlan 2 name VLAN2

VLAN 2 added:

Name: VLAN2

//以上建立vlan,2 就是vlan 的編號,VLAN 號的範圍為1~1001,VLAN2 是該VLAN 的名字:

S1(vlan)#vlan 3 name VLAN3

VLAN 3 added:

Name: VLAN3

S1(vlan)#exit

APPLY completed.

Exiting….

//退出VLAN模式,建立的VLAN立即生效:

【提示】交換機中的VLAN 信息存放在單獨的檔案中flash:vlan.dat,因此如果要完全清除

交換機的配置,除了使用“erase starting-config”命令外,還要使用“delete

flash:vlan.dat”命令把VLAN 資料移除。

【提示】新的IOS 版本中,可以在全局配置模式中建立VLAN,如下:

S1(config)#vlan 2

S1(config-vlan)#name VLAN2

S1(config-vlan)#exit

S1(config)#vlan 3

S1(config-vlan)#name VLAN3

(3)步驟3:把連線埠劃分在VLAN 中

S1(config)#interface f0/1

S1(config-if)#switch mode access

//以上把交換機連線埠的模式改為access 模式,說明該連線埠是用于連線電腦的,而不是用

于trunk

S1(config-if)#switch access vlan 2

//然後把該連線埠f0/1 劃分到VLAN 2 中

S1(config)#interface f0/2

S1(config-if)#switch mode access

S1(config-if)#switch access vlan 3

【提示】默認時,所有交換機接口都在VLAN 1 上,VLAN 1 是不能移除的。如果有多個接口

需要劃分到同一VLAN 下,也可以採用如下方式以節約時間,註意破折號前後的空格:

S1(config)#interface range f0/2 -3

S1(config-rang-if)#switch mode access

S1(config-rang-if)#switch access vlan 2

【提示】如果要移除VLAN,使用“no vlan 2”命令即可。移除某一VLAN後,要記得把該VLAN

上的連線埠重新劃分到別的VLAN上,否則將導致連線埠的“消失”。

4. 實驗調試

(1)查看VLAN

使用“show vlan”或者“show vlan brief”命令可以查看VLAN 的信息,以及每個

VLAN 上有什麽連線埠。要註意這裏隻能看到的是本交換機上哪個連線埠在VLAN 上,而不能看到

其他交換機的連線埠在什麽VLAN 上。如下:

SW1#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1.default active Fa0/1,Fa0/2,Fa0/3,Fa0/4

Fa0/5,Fa0/6,Fa0/7,Fa0/8

Fa0/9,Fa0/10,Fa0/11,Fa0/12

Fa0/13,Fa0/14,Fa0/16,Fa0/17

Fa0/18,Fa0/19,Fa0/20,Fa0/21

Fa0/22,Fa0/23,Fa0/24,Gi0/1

Gi0/2

2.VLAN2 active

3.VLAN3 active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

(此處省略)

//在交換上,VLAN1是默認VLAN,不能移除,也不能改名。此外還有1002、1003等VLAN的存

在。

(2)VLAN 間的通信

由于f0/1 和f0/2 屬于不同的VLAN,從R1 ping 192.168.12.2 應該不能成功了。

互聯方式

(1)邊界路由。

(2)“獨臂”路由。

(3)MPOA路由。

(4)第三層交換。

虛擬區域網路

相關詞條

其它詞條